#bitcoin-core-dev Meeting

Meeting started by wumpus at 18:59:45 UTC (full logs).

Meeting summary

  1. short update on segwit and segnet4 (wumpus, 19:01:43)
    1. https://github.com/bitcoin/bitcoin/compare/0.12...sipa:segwit (btcdrak, 19:08:18)
    2. ACTION: start generating mtp violating transactions (gmaxwell) (wumpus, 19:08:21)

  2. net-refactor update (wumpus, 19:11:21)
  3. softfork backports (wumpus, 19:18:59)
    1. ACTION: #7543 has 5 tested ACKs so far. It should be ready for merge (wumpus, 19:22:52)
    2. https://github.com/theuni/bitcoin/tree/net-refactor10 (wumpus, 19:24:19)

  4. bad chain alerts (wumpus, 19:33:11)
    1. ACTION: disable bad-chain alert for 0.12.1 (wumpus, 19:38:39)

  5. CPFP mining (wumpus, 19:46:32)
    1. ACTION: disable bad-alert detection in master if it doesn't improve enough by 0.13 (and don't forget!) (wumpus, 19:48:33)

  6. p2p encryption/authentication (wumpus, 19:52:53)
    1. https://github.com/sipa/ctaes (wumpus, 19:57:31)


Meeting ended at 19:59:56 UTC (full logs).

Action items

  1. start generating mtp violating transactions (gmaxwell)
  2. #7543 has 5 tested ACKs so far. It should be ready for merge
  3. disable bad-chain alert for 0.12.1
  4. disable bad-alert detection in master if it doesn't improve enough by 0.13 (and don't forget!)


Action items, by person

  1. gmaxwell
    1. start generating mtp violating transactions (gmaxwell)
  2. UNASSIGNED
    1. #7543 has 5 tested ACKs so far. It should be ready for merge
    2. disable bad-chain alert for 0.12.1
    3. disable bad-alert detection in master if it doesn't improve enough by 0.13 (and don't forget!)


People present (lines said)

  1. wumpus (76)
  2. morcos (49)
  3. sipa (40)
  4. jonasschnelli (27)
  5. gmaxwell (23)
  6. btcdrak (23)
  7. cfields (20)
  8. petertodd (19)
  9. dgenr8 (6)
  10. Luke-Jr (6)
  11. sdaftuar (6)
  12. jtimon (3)
  13. phantomcircuit (2)
  14. lightningbot (2)
  15. GitHub123 (1)
  16. paveljanik (1)
  17. warren (1)
  18. jl2012 (1)


Generated by MeetBot 0.1.4.