#bitcoin-core-dev Meeting
Meeting started by wumpus at 19:00:08 UTC
(full logs).
Meeting summary
- 
  - https://github.com/bitcoin/bitcoin/issues/9499
    | Use recent-rejects, orphans, and recently-replaced txn for
    compact-block-reconstruction by TheBlueMatt · Pull Request #9499 ·
    bitcoin/bitcoin · GitHub (gribble,
    19:02:27)
 
  - https://github.com/bitcoin/bitcoin/issues/9375
    | Relay compact block messages prior to full block connection by
    TheBlueMatt · Pull Request #9375 · bitcoin/bitcoin · GitHub (gribble,
    19:02:29)
 
  - https://github.com/bitcoin/bitcoin/issues/9441
    | Net: Massive speedup. Net locks overhaul by theuni · Pull Request
    #9441 · bitcoin/bitcoin · GitHub (gribble,
    19:02:31)
 
  - https://github.com/bitcoin/bitcoin/issues/8775
    | RPC refactoring: Access wallet using new
    GetWalletForJSONRPCRequest by luke-jr · Pull Request #8775 ·
    bitcoin/bitcoin · GitHub (gribble,
    19:03:52)
 
  - https://github.com/bitcoin/bitcoin/issues/9441
    | Net: Massive speedup. Net locks overhaul by theuni · Pull Request
    #9441 · bitcoin/bitcoin · GitHub (gribble,
    19:04:03)
 
  - https://github.com/bitcoin/bitcoin/issues/9519
    | Exclude RBF replacement txs from fee estimation by morcos · Pull
    Request #9519 · bitcoin/bitcoin · GitHub (gribble,
    19:06:30)
 
  - https://github.com/bitcoin/bitcoin/issues/9512
    | Fix various things -fsanitize complains about by sipa · Pull
    Request #9512 · bitcoin/bitcoin · GitHub (gribble,
    19:07:34)
 
  - https://github.com/bitcoin/bitcoin/issues/9512
    | Fix various things -fsanitize complains about by sipa · Pull
    Request #9512 · bitcoin/bitcoin · GitHub (gribble,
    19:08:06)
 
  - https://github.com/bitcoin/bitcoin/issues/9380
    | Separate different uses of minimum fees by morcos · Pull Request
    #9380 · bitcoin/bitcoin · GitHub (gribble,
    19:08:25)
 
  - https://github.com/bitcoin/bitcoin/issues/9484
    | Introduce assumevalid setting to skip validation presumed valid
    scripts. by gmaxwell · Pull Request #9484 · bitcoin/bitcoin · GitHub
    (gribble,
    19:09:14)
 
  - ACTION: review before
    monday : 9484, 9499, 9375, 9441 (wumpus,
    19:10:51)
 
  - https://github.com/bitcoin/bitcoin/issues/9380
    | Separate different uses of minimum fees by morcos · Pull Request
    #9380 · bitcoin/bitcoin · GitHub (gribble,
    19:11:28)
 
  - https://github.com/bitcoin/bitcoin/issues/9512
    | Fix various things -fsanitize complains about by sipa · Pull
    Request #9512 · bitcoin/bitcoin · GitHub (gribble,
    19:12:11)
 
 
- the concept of dust being tied to minrelaytxfee (wumpus, 19:14:30)
  - https://github.com/bitcoin/bitcoin/issues/8456
    | [RPC] Simplified bumpfee command. by mrbandrews · Pull Request
    #8456 · bitcoin/bitcoin · GitHub (gribble,
    19:22:24)
 
  - https://github.com/bitcoin/bitcoin/issues/8501
    | Add mempool statistics collector by jonasschnelli · Pull Request
    #8501 · bitcoin/bitcoin · GitHub (gribble,
    19:22:26)
 
  - https://github.com/bitcoin/bitcoin/issues/8654
    | Reuse sighash computations across evaluation (rebase of #4562) by
    jl2012 · Pull Request #8654 · bitcoin/bitcoin · GitHub (gribble,
    19:22:28)
 
  - https://github.com/bitcoin/bitcoin/issues/8723
    | [Wallet] Add support for flexible BIP32/HD keypath-scheme by
    jonasschnelli · Pull Request #8723 · bitcoin/bitcoin · GitHub (gribble,
    19:22:29)
 
  - https://github.com/bitcoin/bitcoin/issues/8755
    | Implement excessive sighashing protection policy with tight
    sighash estimation by jl2012 · Pull Request #8755 · bitcoin/bitcoin
    · GitHub (gribble,
    19:22:30)
 
  - https://github.com/bitcoin/bitcoin/issues/9294
    | Use internal HD chain for change outputs (hd split) by
    jonasschnelli · Pull Request #9294 · bitcoin/bitcoin · GitHub (gribble,
    19:23:05)
 
  - https://github.com/bitcoin/bitcoin/issues/9377
    | fundrawtransaction: Keep change-output keys by default, make it
    optional by jonasschnelli · Pull Request #9377 · bitcoin/bitcoin ·
    GitHub (gribble,
    19:23:51)
 
  - https://github.com/bitcoin/bitcoin/issues/9294
    | Use internal HD chain for change outputs (hd split) by
    jonasschnelli · Pull Request #9294 · bitcoin/bitcoin · GitHub (gribble,
    19:30:09)
 
  - https://github.com/bitcoin/bitcoin/issues/9294
    | Use internal HD chain for change outputs (hd split) by
    jonasschnelli · Pull Request #9294 · bitcoin/bitcoin · GitHub (gribble,
    19:31:55)
 
  - https://github.com/bitcoin/bitcoin/issues/8723
    | [Wallet] Add support for flexible BIP32/HD keypath-scheme by
    jonasschnelli · Pull Request #8723 · bitcoin/bitcoin · GitHub (gribble,
    19:31:57)
 
  - https://github.com/bitcoin/bitcoin/issues/9490
    | Replace FindLatestBefore used by importmuti with
    FindEarliestAtLeast. by gmaxwell · Pull Request #9490 ·
    bitcoin/bitcoin · GitHub (gribble,
    19:45:53)
 
  - https://github.com/bitcoin/bitcoin/issues/9484
    | Introduce assumevalid setting to skip validation presumed valid
    scripts. by gmaxwell · Pull Request #9484 · bitcoin/bitcoin · GitHub
    (gribble,
    19:46:06)
 
  - https://github.com/bitcoin/bitcoin/issues/9461
    | [Qt] Improve progress display during headers-sync and peer-finding
    by jonasschnelli · Pull Request #9461 · bitcoin/bitcoin · GitHub
    (gribble,
    19:46:08)
 
  - https://github.com/bitcoin/bitcoin/issues/9419
    | Stop Using cs_main for CNodeState/State() by TheBlueMatt · Pull
    Request #9419 · bitcoin/bitcoin · GitHub (gribble,
    19:48:31)
 
  - https://github.com/bitcoin/bitcoin/issues/1
    | JSON-RPC support for mobile devices ("ultra-lightweight" clients)
    · Issue #1 · bitcoin/bitcoin · GitHub (gribble,
    19:49:39)
 
 
Meeting ended at 19:56:56 UTC
(full logs).
Action items
  - review before monday : 9484, 9499, 9375, 9441
 
People present (lines said)
  - BlueMatt (60)
 
  - jonasschnelli (60)
 
  - wumpus (53)
 
  - luke-jr (39)
 
  - gribble (27)
 
  - sipa (21)
 
  - morcos (21)
 
  - jtimon (11)
 
  - cfields (11)
 
  - instagibbs (10)
 
  - MarcoFalke (5)
 
  - sdaftuar (5)
 
  - CodeShark (3)
 
  - bitcoin-git (3)
 
  - btcdrak (2)
 
  - lightningbot (2)
 
  - petertodd (1)
 
  - michagogo (1)
 
  - achow101 (1)
 
  - jl2012 (1)
 
  - kanzure (1)
 
Generated by MeetBot 0.1.4.