#bitcoin-core-dev Meeting

Meeting started by jonasschnelli at 19:02:18 UTC (full logs).

Meeting summary

    1. https://github.com/bitcoin/bitcoin/issues/10637 | Coin Selection with Murchs algorithm by achow101 · Pull Request #10637 · bitcoin/bitcoin · GitHub (gribble, 19:03:47)
    2. https://github.com/bitcoin/bitcoin/issues/11389 | Support having SegWit always active in regtest by sipa · Pull Request #11389 · bitcoin/bitcoin · GitHub (gribble, 19:05:17)
    3. https://github.com/bitcoin/bitcoin/issues/8498 | Near-Bugfix: Optimization: Minimize the number of times it is checked that no money... by jtimon · Pull Request #8498 · bitcoin/bitcoin · GitHub (gribble, 19:05:20)
    4. https://github.com/bitcoin/bitcoin/issues/11403 | SegWit wallet support by sipa · Pull Request #11403 · bitcoin/bitcoin · GitHub (gribble, 19:05:50)
    5. https://github.com/bitcoin/bitcoin/issues/11449 (wumpus, 19:07:55)
    6. ACTION: achow101 make an issue for coin selection changes in general (wumpus, 19:11:25)

  1. bad block interrogation/invalid block peer banning (wumpus, 19:11:38)
    1. https://github.com/bitcoin/bitcoin/issues/11446 | [WIP] Bad block interrogation by achow101 · Pull Request #11446 · bitcoin/bitcoin · GitHub (gribble, 19:11:54)
    2. https://github.com/bitcoin/bitcoin/issues/10593 | Relax punishment for peers relaying invalid blocks and headers by luke-jr · Pull Request #10593 · bitcoin/bitcoin · GitHub (gribble, 19:14:36)
    3. https://github.com/bitcoin/bitcoin/issues/10512 | Rework same-chain from abusing DoS banning, to explicit checks by luke-jr · Pull Request #10512 · bitcoin/bitcoin · GitHub (gribble, 19:27:31)
    4. https://github.com/bitcoin/bitcoin/issues/10593 | Relax punishment for peers relaying invalid blocks and headers by luke-jr · Pull Request #10593 · bitcoin/bitcoin · GitHub (gribble, 19:31:22)

  2. multiwallet ui (wumpus, 19:37:21)
    1. https://github.com/bitcoin/bitcoin/pull/11383 (jonasschnelli, 19:38:05)

  3. dealing with platform-specific code (sipa) (wumpus, 19:41:03)


Meeting ended at 20:01:57 UTC (full logs).

Action items

  1. achow101 make an issue for coin selection changes in general


Action items, by person

  1. achow101
    1. achow101 make an issue for coin selection changes in general


People present (lines said)

  1. gmaxwell (58)
  2. wumpus (55)
  3. luke-jr (38)
  4. sipa (35)
  5. achow101 (34)
  6. sdaftuar (20)
  7. cfields (18)
  8. jonasschnelli (9)
  9. gribble (8)
  10. BlueMatt (7)
  11. jnewbery (5)
  12. Murch (4)
  13. meshcollider (3)
  14. lightningbot (3)
  15. michagogo (3)
  16. morcos (3)
  17. jtimon (2)
  18. RealM9 (2)
  19. kanzure (1)


Generated by MeetBot 0.1.4.