#bitcoin-core-dev Meeting

Meeting started by wumpus at 19:00:20 UTC (full logs).

Meeting summary

  1. high priority for review (wumpus, 19:01:08)
  2. Slow unit test/Run unit tests in parallel (wumpus, 19:07:16)
    1. https://www.boost.org/doc/libs/1_57_0/libs/test/doc/html/open-issues.html (jonasschnelli, 19:08:17)
    2. https://github.com/bitcoin/bitcoin/issues/12831 | [WIP] Run unit tests in parallel by MarcoFalke · Pull Request #12831 · bitcoin/bitcoin · GitHub (gribble, 19:11:09)
    3. https://github.com/bitcoin/bitcoin/issues/12831 | [WIP] Run unit tests in parallel by MarcoFalke · Pull Request #12831 · bitcoin/bitcoin · GitHub (gribble, 19:11:11)
    4. https://github.com/bitcoin/bitcoin/issues/8650 | Make tests much faster by replacing BOOST_CHECK with FAST_CHECK by JeremyRubin · Pull Request #8650 · bitcoin/bitcoin · GitHub (gribble, 19:13:32)
    5. https://github.com/bitcoin/bitcoin/issues/12831 | [WIP] Run unit tests in parallel by MarcoFalke · Pull Request #12831 · bitcoin/bitcoin · GitHub (gribble, 19:20:21)

  3. multiwallet GUI (wumpus, 19:26:54)
    1. https://github.com/bitcoin/bitcoin/issues/12610 | Multiwallet for the GUI by jonasschnelli · Pull Request #12610 · bitcoin/bitcoin · GitHub (gribble, 19:27:39)
    2. https://github.com/bitcoin/bitcoin/issues/10244 | Refactor: separate gui from wallet and node by ryanofsky · Pull Request #10244 · bitcoin/bitcoin · GitHub (gribble, 19:31:32)
    3. ACTION: dont forget to review High-Priority PRs this week! (MarcoFalke, 19:32:21)


Meeting ended at 19:32:44 UTC (full logs).

Action items

  1. dont forget to review High-Priority PRs this week!


People present (lines said)

  1. wumpus (54)
  2. MarcoFalke (40)
  3. jonasschnelli (33)
  4. sipa (20)
  5. cfields (13)
  6. jnewbery (8)
  7. BlueMatt (8)
  8. jamesob (6)
  9. gribble (6)
  10. meshcollider (5)
  11. achow101 (4)
  12. jtimon (3)
  13. aj (2)
  14. phantomcircuit (2)
  15. lightningbot (2)
  16. Murch (1)
  17. instagibbs (1)
  18. kanzure (1)


Generated by MeetBot 0.1.4.