19:00:04 <wumpus> #startmeeting
19:00:04 <lightningbot> Meeting started Thu Nov 15 19:00:04 2018 UTC.  The chair is wumpus. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:04 <lightningbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:07 <wumpus> #bitcoin-core-dev Meeting: wumpus sipa gmaxwell jonasschnelli morcos luke-jr btcdrak sdaftuar jtimon cfields petertodd kanzure bluematt instagibbs phantomcircuit codeshark michagogo marcofalke paveljanik NicolasDorier jl2012 achow101 meshcollider jnewbery maaku fanquake promag provoostenator
19:00:18 <provoostenator> hi
19:00:20 <meshcollider> hi
19:00:36 <promag> hi
19:00:37 <kanzure> hi.
19:00:57 <wumpus> proposed topics?
19:02:38 <wumpus> #topic high priority for review
19:02:40 <sipa> hi.
19:03:07 <phantomcircuit> hi
19:03:14 <wumpus> https://github.com/bitcoin/bitcoin/projects/8  current high priority PRs are by luke-jr promag achow101 phantomcircuit sipa
19:03:32 <meshcollider> Maybe #14552
19:03:34 <wumpus> anything to add or remove for this week?
19:03:35 <gribble> https://github.com/bitcoin/bitcoin/issues/14552 | wallet: detecting duplicate wallet by comparing the db filename. by ken2812221 · Pull Request #14552 · bitcoin/bitcoin · GitHub
19:03:48 <instagibbs> hi
19:04:09 <wumpus> meshcollider: added
19:04:15 <meshcollider> Thanks
19:04:39 <promag> regarding #14670, it is possible to have appveyor rebase on that instead of master?
19:04:41 <gribble> https://github.com/bitcoin/bitcoin/issues/14670 | http: Fix HTTP server shutdown by promag · Pull Request #14670 · bitcoin/bitcoin · GitHub
19:05:00 <wumpus> luke-jr: please rebase #14532
19:05:02 <gribble> https://github.com/bitcoin/bitcoin/issues/14532 | Never bind INADDR_ANY by default, and warn when doing so explicitly by luke-jr · Pull Request #14532 · bitcoin/bitcoin · GitHub
19:05:18 <wumpus> (should be a small change)
19:05:40 <provoostenator> I like to nominate #11082
19:05:43 <gribble> https://github.com/bitcoin/bitcoin/issues/11082 | Add new bitcoin_rw.conf file that is used for settings modified by this software itself by luke-jr · Pull Request #11082 · bitcoin/bitcoin · GitHub
19:05:51 <promag> I saw several connection problems in some PR's in appveyor and I think 14670 fixes that
19:05:52 <provoostenator> Since I have PR that depends on that.
19:05:58 <wumpus> provoostenator: I don't know anything about appveyor
19:06:06 <MarcoFalke> promag: You'd have to fixup the appveyor yaml, I'd presume
19:06:07 <wumpus> provoostenator: luke-jr already has a PR
19:06:42 <wumpus> really, let's try to get the INADDR_ANY in, it's silly that it takes so long
19:06:57 <wumpus> it's an important security issue in a way
19:07:37 <wumpus> buut I'm fine with adding the _rw one as well if others agree...
19:07:44 <promag> MarcoFalke: you mean manually rebase? because from https://www.appveyor.com/docs/appveyor-yml/ I don't see that's possible out of the box
19:09:07 <MarcoFalke> Git should be installed on the machine, so you could do "git fetch https://github.com/promag/bitcoin branch && git merge FETCH_HEAD" before compiling?
19:10:11 <promag> MarcoFalke: do you think that could go to master temporally?
19:11:34 <provoostenator> wumpus: I'm fine with waiting until this more urgent PR is done, I'll try to help with review
19:11:42 <sipa> i think merging it is preferable
19:11:48 <sipa> (after review, of course)
19:12:01 <wumpus> merging it is certainly preferable, if we can be confident of it
19:12:47 <promag> ok then
19:13:08 <phantomcircuit> wumpus, im reviewing that one now
19:13:15 <MarcoFalke> phantomcircuit: Thx
19:13:18 <wumpus> it's the so-manieth time that particular part of the code was fixed, so I certainly understand people are a bit skeptical, you'll need very good tests
19:13:21 <phantomcircuit> the IsBindAny looks wrong actually...
19:15:03 <phantomcircuit> unless GetByte does some magic
19:15:13 <wumpus> let's review in the PR :)
19:15:22 <wumpus> any other topics?
19:15:26 <phantomcircuit> true sorry
19:16:00 <sipa> short reminder: wallet meeting tomorrow, same time
19:16:34 <wumpus> #action wallet meeting tomorrow, same time (friday 19:00 UTC)
19:18:44 <wumpus> this is a short meeting I suppose!
19:19:11 <sipa> seems so
19:19:58 <wumpus> #endmeeting