19:02:42 <wumpus> #startmeeting
19:02:42 <lightningbot> Meeting started Thu Jan 23 19:02:42 2020 UTC.  The chair is wumpus. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:42 <lightningbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:03:02 <sipsorcery> hi
19:03:05 <wumpus> #bitcoin-core-dev Meeting: wumpus sipa gmaxwell jonasschnelli morcos luke-jr sdaftuar jtimon cfields petertodd kanzure bluematt instagibbs phantomcircuit codeshark michagogo marcofalke paveljanik NicolasDorier jl2012 achow101 meshcollider jnewbery maaku fanquake promag provoostenator aj Chris_Stewart_5 dongcarl gwillen jamesob ken281221 ryanofsky gleb moneyball kvaciral ariard digi_james amiti fjahr
19:03:06 <wumpus> jeremyrubin lightlike emilengler jonatack hebasto jb55
19:03:08 <emilengler> hi
19:03:09 <achow101> hi
19:03:11 <hebasto> hi
19:03:14 <amiti> hi
19:03:19 <jonatack> hi
19:03:36 <fjahr> hi
19:03:47 <wumpus> no proposed topics for today on https://gist.github.com/moneyball/071d608fdae217c2a6d7c35955881d8a
19:03:47 <gwillen> hi
19:03:51 <wumpus> any last minute suggestions?
19:03:57 <sipa> hi
19:04:00 <emilengler> wumpus: yes
19:04:13 <emilengler> let me find just find the PR number
19:04:37 <wumpus> PSA: we're planning to tag the 0.19.1 rc1 right after the meeting, after merging the final backports (#17988)
19:04:39 <gribble> https://github.com/bitcoin/bitcoin/issues/17988 | [0.19] Final backports for 0.19.1 by fanquake · Pull Request #17988 · bitcoin/bitcoin · GitHub
19:04:43 <emilengler> There we go, #17453
19:04:46 <gribble> https://github.com/bitcoin/bitcoin/issues/17453 | gui: Fix intro dialog labels when the prune button is toggled by hebasto · Pull Request #17453 · bitcoin/bitcoin · GitHub
19:05:05 <wumpus> anything specific you'd like to discuss about that?
19:05:06 <emilengler> It isn't that important and also probably too late but I think this PR should get into the code sooner or later
19:05:19 <wumpus> ohh just a review beg :D
19:05:23 <emilengler> It was already said some time ago that it should get into 0.19.1
19:05:52 <emilengler> I was more asking what's the current state of it
19:07:36 <wumpus> ok, looks like it has some ACKs, should me merged soon, but I guess it's too late for 0.19.1
19:07:51 <hebasto> I'd rather wait for jonasschnelli's ACK
19:07:55 <wumpus> it should have had a 0.19 (backport) label
19:07:59 <wumpus> right
19:08:14 <wumpus> #topic High priority for review
19:08:21 <emilengler> Its predecessor had it (#17035)
19:08:26 <gribble> https://github.com/bitcoin/bitcoin/issues/17035 | qt: Fix text display when state of prune button is changed by emilengler · Pull Request #17035 · bitcoin/bitcoin · GitHub
19:08:41 <wumpus> https://github.com/bitcoin/bitcoin/projects/8   9 blockers, 6 chasing concept ACK right now
19:09:52 <wumpus> anything to add/remove, or is ready for merge?
19:11:51 <wumpus> #17957 seems pretty close
19:11:53 <gribble> https://github.com/bitcoin/bitcoin/issues/17957 | Serialization improvements step 3 (compression.h) by sipa · Pull Request #17957 · bitcoin/bitcoin · GitHub
19:12:01 <wumpus> also #16702
19:12:04 <gribble> https://github.com/bitcoin/bitcoin/issues/16702 | p2p: supplying and using asmap to improve IP bucketing in addrman by naumenkogs · Pull Request #16702 · bitcoin/bitcoin · GitHub
19:12:44 <wumpus> though jamesob had some new review comments, I think most of those can be done in follow-up PRs
19:13:28 <wumpus> there's also alredy #17812
19:13:30 <gribble> https://github.com/bitcoin/bitcoin/issues/17812 | config, test: asmap functional tests and feature refinements by jonatack · Pull Request #17812 · bitcoin/bitcoin · GitHub
19:14:13 <jonatack> yes - i have some questions on the unit tests to discuss with gleb, and will update the follow-up this weekend
19:15:27 <wumpus> #17737 has one ACK, I've been looking at it and will likely ACK it soon too, but it could use some more review still
19:15:28 <jonatack> (+1 on getting it in soon)
19:15:30 <gribble> https://github.com/bitcoin/bitcoin/issues/17737 | Add ChainstateManager, remove BlockManager global by jamesob · Pull Request #17737 · bitcoin/bitcoin · GitHub
19:15:57 <wumpus> jonatack: thanks, yes there's been some more questions about the unit tests, there's some functions (like the interpreter function) that are not tested directly and probably should
19:16:23 <wumpus> then again, this could all be added later, I have the idea it would be good to get the basic functionality in soon so iteration can be quicker
19:16:35 <jamesob> wumpus (and anyone else): thanks for the review
19:17:11 <jonatack> yes, will review https://github.com/sipa/asmap/pull/2 by jamesob
19:17:46 <wumpus> #16974 seems ready for merge
19:17:47 <gribble> https://github.com/bitcoin/bitcoin/issues/16974 | Walk pindexBestHeader back to ChainActive().Tip() if it is invalid by TheBlueMatt · Pull Request #16974 · bitcoin/bitcoin · GitHub
19:17:50 <wumpus> lots of (ut)ACKs
19:18:26 <wumpus> #16442 gives me the good old unicorn
19:18:31 <gribble> https://github.com/bitcoin/bitcoin/issues/16442 | Serve BIP 157 compact filters by jimpo · Pull Request #16442 · bitcoin/bitcoin · GitHub
19:19:09 <jamesob> re: 16442: I think gleb and ariard have some concept concerns that should be articulated somewhere at some point
19:19:12 <wumpus> ah, works not, that one has a lot of open comments still and no ACKs
19:20:26 <jamesob> the gist of which is, as far as I can tell, that neutrino is sort of useless for lightning because for sybil-resistance, lightning users need to verify all channel openings on-chain, which would result in downloading every incoming block anyway. but this is probably out of scope for this meeting
19:20:39 <wumpus> okay, yes, would be good to discuss concept concerns first before spending a lot of time reviewing code details
19:21:14 <sipa> jamesob: that sounds like a discussion for the ML
19:21:31 <jamesob> agreed
19:21:36 <wumpus> good point
19:22:45 <wumpus> ok then there is fanquake's MacOS toolchain update (#16392) which should be straightforward, but I think it's held up on a non-MacoSX way to extract the SDK, not so much review
19:22:48 <gribble> https://github.com/bitcoin/bitcoin/issues/16392 | build: macOS toolchain update by fanquake · Pull Request #16392 · bitcoin/bitcoin · GitHub
19:24:06 <wumpus> #16411 just needs more review
19:24:11 <gribble> https://github.com/bitcoin/bitcoin/issues/16411 | BIP-325: Signet support by kallewoof · Pull Request #16411 · bitcoin/bitcoin · GitHub
19:24:12 <wumpus> I think that was all of them
19:24:34 <wumpus> ah no forgot #17261
19:24:39 <gribble> https://github.com/bitcoin/bitcoin/issues/17261 | Make ScriptPubKeyMan an actual interface and the wallet to have multiple by achow101 · Pull Request #17261 · bitcoin/bitcoin · GitHub
19:25:14 <instagibbs> that one is getting close hopefully
19:25:36 <wumpus> seems it has ACKs, if my comment isn't really an issue then it can be merged soon
19:25:58 <wumpus> I'm really not sure about non-primitive constants in header files in C++
19:26:25 <wumpus> https://github.com/bitcoin/bitcoin/pull/17261#pullrequestreview-345490342 this used to be a problem at some point, but maybe not anymore
19:27:18 <wumpus> at least in the rest of our code we define string etc constants in the cpp and only reference them in the header
19:27:21 <achow101> wouldn't a simple test of printing out the memory address of that constant resolve it?
19:27:33 <wumpus> that only proves it for one compiler
19:27:47 <wumpus> or linker
19:28:16 <wumpus> but yeah it's a way…
19:28:52 <wumpus> any other topics?
19:29:10 <kanzure> just another request for topics for upcoming physical meeting
19:29:38 <wumpus> #action send topic suggestions for upcoming physical meeting to kanzure
19:29:48 <kanzure> basically, topics that you would like to hear about or you talk about
19:30:04 <kanzure> not mandatory, but it does help organize and figure out how much stuff is on everyone's minds
19:31:01 <wumpus> #endmeeting