19:00:14 <meshcollider> #startmeeting
19:00:14 <lightningbot> Meeting started Fri Aug 14 19:00:14 2020 UTC.  The chair is meshcollider. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:14 <lightningbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:17 <achow101> hi
19:00:22 <meshcollider> #bitcoin-core-dev Wallet Meeting: wumpus sipa gmaxwell jonasschnelli morcos luke-jr sdaftuar jtimon cfields petertodd kanzure bluematt instagibbs phantomcircuit codeshark michagogo marcofalke paveljanik NicolasDorier jl2012 achow101 meshcollider jnewbery maaku fanquake promag provoostenator aj Chris_Stewart_5 dongcarl gwillen jamesob ken281221 ryanofsky gleb moneyball ariard digi_james amiti fjahr
19:00:22 <meshcollider> jeremyrubin emilengler jonatack hebasto jb55
19:00:33 <fjahr> hi
19:01:26 <meshcollider> Any topics this week?
19:02:23 <achow101> any wallet PRs in need of review?
19:02:35 <achow101> that are reasonably close to being merged?
19:02:45 <kanzure> hi
19:03:28 <fjahr> I think #14582 is interesting but long forgotten
19:03:30 <gribble> https://github.com/bitcoin/bitcoin/issues/14582 | wallet: always do avoid partial spends if fees are within a specified range by kallewoof · Pull Request #14582 · bitcoin/bitcoin · GitHub
19:03:52 <instagibbs> hi
19:04:11 <fjahr> enough concept ACK now I think and a tested ACK from me so not super close but still
19:04:13 <meshcollider> achow101: time to review-beg for your coin selection PRs?
19:05:07 <jonatack> hi
19:05:23 <achow101> meshcollider: yep
19:05:36 <achow101> if sqlite is too big/scary to review, how about coin selection, almost as scary!
19:05:50 <achow101> #17458 is close to being merged. 3 ACKs
19:05:53 <gribble> https://github.com/bitcoin/bitcoin/issues/17458 | Refactor OutputGroup effective value calculations and filtering to occur within the struct by achow101 · Pull Request #17458 · bitcoin/bitcoin · GitHub
19:06:04 <achow101> #17331 is next up in that stack
19:06:08 <gribble> https://github.com/bitcoin/bitcoin/issues/17331 | Use effective values throughout coin selection by achow101 · Pull Request #17331 · bitcoin/bitcoin · GitHub
19:07:59 <meshcollider> #16841 is also nearly rtm
19:08:01 <gribble> https://github.com/bitcoin/bitcoin/issues/16841 | Replace GetScriptForWitness with GetScriptForDestination by meshcollider · Pull Request #16841 · bitcoin/bitcoin · GitHub
19:09:02 <achow101> yes, getting that in would be nice
19:10:42 <meshcollider> Anything else anyone wants to discuss? Perhaps #19700 vs #19671 ?
19:10:44 <gribble> https://github.com/bitcoin/bitcoin/issues/19671 | wallet: Remove -zapwallettxes by achow101 · Pull Request #19671 · bitcoin/bitcoin · GitHub
19:10:45 <gribble> https://github.com/bitcoin/bitcoin/issues/19700 | wallet: Replace -zapwallettxes with wallet tool command by achow101 · Pull Request #19700 · bitcoin/bitcoin · GitHub
19:11:20 <achow101> 19700 feels way too involved for something that is barely used
19:11:39 <achow101> i prefer removing -zapwallettxes outright
19:12:11 <meshcollider> But jonasschnelli just reviewed it, does that mean he prefers it?
19:12:34 <achow101> good question
19:12:35 <meshcollider> people need to say "I prefer this one or this one"
19:13:55 <meshcollider> Well I don't think there is enough people online to discuss it much
19:14:24 <achow101> I think it's also reasonable to reintroduce it in the wallettool if people complain about it being gone
19:14:49 <meshcollider> Yes it doesn't need to be immediate if it's moving to the tool anyway
19:15:45 <meshcollider> #action Please take a look at those two PRs and comment your preference ^
19:16:00 <meshcollider> I guess that's all for this week
19:16:07 <meshcollider> #endmeeting