#bitcoin-dev Meeting

Meeting started by btcdrak at 19:05:11 UTC (full logs).

Meeting summary

  1. mempool memory usage (btcdrak, 19:07:13)
    1. ACTION: continue research (btcdrak, 19:20:52)

  2. leveldb replacement (btcdrak, 19:21:03)
    1. ACTION: continue research and benchmarking (btcdrak, 19:25:23)

  3. versionbits (btcdrak, 19:25:34)
    1. ACTION: review versionbits implementation https://github.com/bitcoin/bitcoin/pull/6816 (btcdrak, 19:28:25)

  4. mailing list (btcdrak, 19:28:58)
    1. http://lists.linuxfoundation.org/pipermail/bitcoin-dev/2015-October/011591.html (btcdrak, 19:29:46)
    2. ACTION: tell SF list about new lists (jgarzik, 19:32:34)
    3. lists.linuxfoundation.org/mailman/listinfo/bitcoin-discuss (btcdrak, 19:32:38)

  5. Median Past locktime (btcdrak, 19:33:50)
    1. PR https://github.com/bitcoin/bitcoin/pull/6566 (btcdrak, 19:34:00)
    2. ACTION: review https://github.com/bitcoin/bitcoin/pull/6566 (btcdrak, 19:36:11)

  6. CLTV softfork deployment (btcdrak, 19:37:03)
    1. https://github.com/bitcoin/bitcoin/pull/6707 (btcdrak, 19:40:28)
    2. https://github.com/bitcoin/bitcoin/pull/6706 (btcdrak, 19:40:35)
    3. https://github.com/bitcoin/bitcoin/pull/6351 (btcdrak, 19:40:53)
    4. ACTION: review #6707 #6706 #6351 for CLTV deployment. (gmaxwell, 19:42:02)
    5. ACTION: backport MPL to 0.10 and 0.11 (btcdrak, 20:01:02)


Meeting ended at 20:01:24 UTC (full logs).

Action items

  1. continue research
  2. continue research and benchmarking
  3. review versionbits implementation https://github.com/bitcoin/bitcoin/pull/6816
  4. tell SF list about new lists
  5. review https://github.com/bitcoin/bitcoin/pull/6566
  6. review #6707 #6706 #6351 for CLTV deployment.
  7. backport MPL to 0.10 and 0.11


People present (lines said)

  1. btcdrak (70)
  2. sipa (64)
  3. gmaxwell (59)
  4. kanzure_ (19)
  5. BlueMatt (19)
  6. morcos (17)
  7. petertodd (13)
  8. CodeShark (13)
  9. jgarzik (12)
  10. maaku (7)
  11. kanzure (5)
  12. jcorgan (4)
  13. Luke-Jr (4)
  14. jonasschnelli (4)
  15. sdaftuar (3)
  16. lightningbot` (2)
  17. luke-jr_ (1)


Generated by MeetBot 0.1.4.