#lightning-dev Meeting

Meeting started by rusty at 20:05:59 UTC (full logs).

Meeting summary

  1. https://github.com/lightningnetwork/lightning-rfc/pull/593 (rusty, 20:06:45)
    1. Ping bitconner BlueMatt cdecker jb55 jimpo niftynei pm47 roasbeef sstone and anyone else i missed. (rusty, 20:09:19)
    2. ACTION: cdecker to create new varint onion proposal: 0 = legacy, non-0 = varint TLV-stream-length-before-hmac. Details in proposal, but we seem to have consensus. (rusty, 20:31:58)

  2. https://github.com/lightningnetwork/lightning-rfc/pull/607 vs https://github.com/lightningnetwork/lightning-rfc/pull/603 FIGHT! (rusty, 20:32:56)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/102 (roasbeef, 20:41:45)
    2. ACTION: bitconnor and rusty to flip coins until TLV proposals unified. (rusty, 21:17:32)


Meeting ended at 21:18:01 UTC (full logs).

Action items

  1. cdecker to create new varint onion proposal: 0 = legacy, non-0 = varint TLV-stream-length-before-hmac. Details in proposal, but we seem to have consensus.
  2. bitconnor and rusty to flip coins until TLV proposals unified.


Action items, by person

  1. cdecker
    1. cdecker to create new varint onion proposal: 0 = legacy, non-0 = varint TLV-stream-length-before-hmac. Details in proposal, but we seem to have consensus.
  2. rusty
    1. bitconnor and rusty to flip coins until TLV proposals unified.


People present (lines said)

  1. rusty (82)
  2. bitconner (60)
  3. cdecker (53)
  4. t-bast (43)
  5. roasbeef (40)
  6. lightningbot (2)
  7. jtimon (2)


Generated by MeetBot 0.1.4.