#lightning-dev Meeting

Meeting started by t-bast at 19:06:09 UTC (full logs).

Meeting summary

  1. Wumbo (t-bast, 19:06:34)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/596 (t-bast, 19:07:07)
    2. ACTION: t-bast merge 596 and work with araspitzu on advisory PR for scaling confs (t-bast, 19:12:08)

  2. TLV extensions (t-bast, 19:12:18)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/714 (t-bast, 19:12:26)
    2. ACTION: t-bast give a few days for other people to potentially chime in on Github, then merge 714 (t-bast, 19:32:17)

  3. networks in init message (t-bast, 19:32:37)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/682 (t-bast, 19:32:40)
    2. ACTION: rebase and merge 682 (t-bast, 19:37:42)

  4. a home for Bolts (t-bast, 19:37:59)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/738 (t-bast, 19:38:05)
    2. https://github.com/GitbookIO/gitbook/blob/master/docs/structure.md (t-bast, 19:44:31)
    3. https://docs.gitbook.com/integrations/github/content-configuration#summary (t-bast, 19:46:21)
    4. ACTION: discuss with the OP the possibility of doing this in a fork of the repo (t-bast, 19:48:15)
    5. ACTION: rusty to get in touch with OP about DNS hand-over (t-bast, 19:48:16)

  5. Stuck channels (t-bast, 19:48:32)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/740 (t-bast, 19:48:35)
    2. ACTION: keep exploring solutions to stuck channels, discuss on Github (t-bast, 20:11:00)

  6. Decoy node_ids and poor man rendezvous (t-bast, 20:11:27)
    1. https://gist.github.com/t-bast/9972bfe9523bb18395bdedb8dc691faf (t-bast, 20:11:47)
    2. ACTION: look at latest developments on anchor outputs PR (t-bast, 20:36:39)
    3. ACTION: cdecker to investigate full sphinx rendezvous possibilities (t-bast, 20:36:59)
    4. ACTION: tear decoys proposal apart on github until we're satisfied (t-bast, 20:37:25)


Meeting ended at 20:37:57 UTC (full logs).

Action items

  1. t-bast merge 596 and work with araspitzu on advisory PR for scaling confs
  2. t-bast give a few days for other people to potentially chime in on Github, then merge 714
  3. rebase and merge 682
  4. discuss with the OP the possibility of doing this in a fork of the repo
  5. rusty to get in touch with OP about DNS hand-over
  6. keep exploring solutions to stuck channels, discuss on Github
  7. look at latest developments on anchor outputs PR
  8. cdecker to investigate full sphinx rendezvous possibilities
  9. tear decoys proposal apart on github until we're satisfied


Action items, by person

  1. cdecker
    1. cdecker to investigate full sphinx rendezvous possibilities
  2. rusty
    1. rusty to get in touch with OP about DNS hand-over
  3. t-bast
    1. t-bast merge 596 and work with araspitzu on advisory PR for scaling confs
    2. t-bast give a few days for other people to potentially chime in on Github, then merge 714
  4. UNASSIGNED
    1. rebase and merge 682
    2. discuss with the OP the possibility of doing this in a fork of the repo
    3. keep exploring solutions to stuck channels, discuss on Github
    4. look at latest developments on anchor outputs PR
    5. tear decoys proposal apart on github until we're satisfied


People present (lines said)

  1. t-bast (124)
  2. roasbeef (52)
  3. rusty (41)
  4. cdecker (37)
  5. BlueMatt (31)
  6. joostjgr (17)
  7. niftynei (9)
  8. lightningbot (2)
  9. ariard_ (1)


Generated by MeetBot 0.1.4.