#lightning-dev Meeting

Meeting started by t-bast at 20:09:38 UTC (full logs).

Meeting summary

  1. Update test vectors to static_remotekey (t-bast, 20:10:27)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/758 (t-bast, 20:10:30)
    2. ACTION: ACK on PR when test vectors have been verified by other implementations, then apply (t-bast, 20:12:43)

  2. Clarify TLV record uniqueness in streams (t-bast, 20:13:02)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/777 (t-bast, 20:13:05)
    2. ACTION: bitconner to comment, condense rationale paragraphs and then apply (t-bast, 20:15:37)

  3. varint / bigsize clarification (t-bast, 20:15:57)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/778 (t-bast, 20:15:59)
    2. ACTION: Decide whether we want to keep the paragraph mentioning Bitcoin varint or not, then apply (t-bast, 20:22:34)
    3. ACTION: Apply #778 (t-bast, 20:24:01)

  4. flip(B) is incorrectly implemented, so we instead fix the spec xD (t-bast, 20:24:18)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/779 (t-bast, 20:24:33)
    2. https://imgflip.com/i/42sldk (t-bast, 20:31:03)
    3. ACTION: fix spellchecker, wait for ACKs and apply (t-bast, 20:35:47)

  5. mempool-pinning issues (t-bast, 20:37:14)
    1. ACTION: ariard to draft preimage-watching and htlc lockdown proposals (t-bast, 21:16:52)


Meeting ended at 21:21:14 UTC (full logs).

Action items

  1. ACK on PR when test vectors have been verified by other implementations, then apply
  2. bitconner to comment, condense rationale paragraphs and then apply
  3. Decide whether we want to keep the paragraph mentioning Bitcoin varint or not, then apply
  4. Apply #778
  5. fix spellchecker, wait for ACKs and apply
  6. ariard to draft preimage-watching and htlc lockdown proposals


Action items, by person

  1. ariard
    1. ariard to draft preimage-watching and htlc lockdown proposals
  2. bitconner
    1. bitconner to comment, condense rationale paragraphs and then apply
  3. UNASSIGNED
    1. ACK on PR when test vectors have been verified by other implementations, then apply
    2. Decide whether we want to keep the paragraph mentioning Bitcoin varint or not, then apply
    3. Apply #778
    4. fix spellchecker, wait for ACKs and apply


People present (lines said)

  1. t-bast (75)
  2. ariard (74)
  3. roasbeef (67)
  4. cdecker (52)
  5. bitconner (16)
  6. harding (3)
  7. michaelfolkson (3)
  8. lightningbot (2)
  9. ja (1)


Generated by MeetBot 0.1.4.