#lightning-dev Meeting

Meeting started by niftynei at 20:11:28 UTC (full logs).

Meeting summary

    1. agenda at https://github.com/lightningnetwork/lightning-rfc/issues/790 (niftynei, 20:12:00)

  1. CLTV delta recommendations (niftynei, 20:13:18)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/785 (niftynei, 20:13:27)
    2. ACTION: t-bast to update PR: bolt 11 writers MUST specify min-final-expiry-delta (t-bast, 20:17:41)

  2. PR #787 add missing MAC check in Act Three (niftynei, 20:19:08)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/787 (niftynei, 20:19:12)
    2. ACTION: niftynei to merge PR #787 (niftynei, 20:23:06)

  3. FoaF and rebalancing (niftynei, 20:25:22)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/780 (niftynei, 20:26:52)
    2. ACTION: renepick1 to consider feedback and update proposal/PR etc (niftynei, 20:44:29)

  4. anchor outputs (niftynei, 20:44:50)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/688 (niftynei, 20:45:20)
    2. ACTION: t-bast + rusty to work on interop testing with lnd's anchor outputs impl; will update at next spec meeting (niftynei, 20:54:05)

  5. protocol test suite (niftynei, 20:54:25)
    1. https://github.com/rustyrussell/lnprototest (rusty, 20:55:04)
    2. https://github.com/rustyrussell/lnprototest (niftynei, 20:55:28)
    3. ACTION: niftynei to write dual funding prototests to dogfood the lnprototest docs (niftynei, 21:02:00)
    4. ACTION: lnd + eclair to investigate the runner implementation requirements (time permitting) ;) (niftynei, 21:03:01)


Meeting ended at 21:03:59 UTC (full logs).

Action items

  1. t-bast to update PR: bolt 11 writers MUST specify min-final-expiry-delta
  2. niftynei to merge PR #787
  3. renepick1 to consider feedback and update proposal/PR etc
  4. t-bast + rusty to work on interop testing with lnd's anchor outputs impl; will update at next spec meeting
  5. niftynei to write dual funding prototests to dogfood the lnprototest docs
  6. lnd + eclair to investigate the runner implementation requirements (time permitting) ;)


Action items, by person

  1. niftynei
    1. niftynei to merge PR #787
    2. niftynei to write dual funding prototests to dogfood the lnprototest docs
  2. renepick1
    1. renepick1 to consider feedback and update proposal/PR etc
  3. rusty
    1. t-bast + rusty to work on interop testing with lnd's anchor outputs impl; will update at next spec meeting
  4. t-bast
    1. t-bast to update PR: bolt 11 writers MUST specify min-final-expiry-delta
    2. t-bast + rusty to work on interop testing with lnd's anchor outputs impl; will update at next spec meeting


People present (lines said)

  1. niftynei (46)
  2. t-bast (36)
  3. rusty (35)
  4. roasbeef (31)
  5. renepick1 (24)
  6. cdecker (12)
  7. lndbot (8)
  8. lightningbot (2)


Generated by MeetBot 0.1.4.