#lightning-dev Meeting

Meeting started by t-bast at 19:06:45 UTC (full logs).

Meeting summary

    1. https://github.com/lightningnetwork/lightning-rfc/issues/802 (t-bast, 19:07:10)

  1. Bolt 4 clarification (t-bast, 19:07:43)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/801 (t-bast, 19:07:54)

  2. Claiming revoked anchor commit txs in a single tx (t-bast, 19:11:08)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/803 (t-bast, 19:11:11)
    2. https://twitter.com/BitMEXResearch/status/1305794706702569472?s=20 (roasbeef, 19:16:42)
    3. https://forkmonitor.info/lightning (roasbeef, 19:17:06)
    4. ACTION: discuss wording on the PR (t-bast, 19:19:58)

  3. clarify message ordering post-reconnect (t-bast, 19:20:28)
    1. https://github.com/lightningnetwork/lightning-rfc/issues/794 (t-bast, 19:20:31)
    2. ACTION: check implementations behavior in the scenario described in the issue (t-bast-official, 19:44:00)
    3. ACTION: figure out a good writeup to clarify the spec (t-bast-official, 19:44:35)

  4. Evaluate historical min_relay_fee to improve update_fee in anchors (t-bast, 19:45:44)
  5. Upfront payments / DoS protection (t-bast, 19:48:52)
    1. ACTION: t-bast summarize existing proposals / attacks / threat models (t-bast, 20:12:07)
    2. ACTION: rusty can you detail your token idea? (t-bast, 20:12:34)


Meeting ended at 20:19:25 UTC (full logs).

Action items

  1. discuss wording on the PR
  2. check implementations behavior in the scenario described in the issue
  3. figure out a good writeup to clarify the spec
  4. t-bast summarize existing proposals / attacks / threat models
  5. rusty can you detail your token idea?


Action items, by person

  1. rusty
    1. rusty can you detail your token idea?
  2. t-bast
    1. t-bast summarize existing proposals / attacks / threat models
  3. UNASSIGNED
    1. discuss wording on the PR
    2. check implementations behavior in the scenario described in the issue
    3. figure out a good writeup to clarify the spec


People present (lines said)

  1. roasbeef (131)
  2. t-bast (81)
  3. rusty (36)
  4. ariard (14)
  5. BlueMatt (8)
  6. joostjgr (8)
  7. lndbot (8)
  8. niftynei (7)
  9. t-bast-official (6)
  10. cdecker (6)
  11. lightningbot (2)
  12. ja (1)


Generated by MeetBot 0.1.4.