#bitcoin-core-dev Meeting
Meeting started by wumpus at 19:00:54 UTC
(full logs).
Meeting summary
- High priority for review (wumpus, 19:02:29)
  - https://github.com/bitcoin/bitcoin/issues/11082
    | Add new bitcoin_rw.conf file that is used for settings modified by
    this software itself by luke-jr · Pull Request #11082 ·
    bitcoin/bitcoin · GitHub (gribble,
    19:03:13)
- https://github.com/bitcoin/bitcoin/issues/14491
    | Allow descriptor imports with importmulti by MeshCollider · Pull
    Request #14491 · bitcoin/bitcoin · GitHub (gribble,
    19:03:16)
- https://github.com/bitcoin/bitcoin/issues/14711
    | Remove uses of chainActive and mapBlockIndex in wallet code by
    ryanofsky · Pull Request #14711 · bitcoin/bitcoin · GitHub (gribble,
    19:03:21)
- https://github.com/bitcoin/bitcoin/issues/14897
    | randomize GETDATA(tx) request order and introduce bias toward
    outbound by naumenkogs · Pull Request #14897 · bitcoin/bitcoin ·
    GitHub (gribble,
    19:03:23)
- https://github.com/bitcoin/bitcoin/issues/15153
    | gui: Add Open Wallet menu by promag · Pull Request #15153 ·
    bitcoin/bitcoin · GitHub (gribble,
    19:03:25)
- https://github.com/bitcoin/bitcoin/issues/15226
    | Allow creating blank (empty) wallets (alternative) by achow101 ·
    Pull Request #15226 · bitcoin/bitcoin · GitHub (gribble,
    19:03:27)
- https://github.com/bitcoin/bitcoin/issues/15225
    | GUI: Change the receive button to respond to keypool state
    changing by achow101 · Pull Request #15225 · bitcoin/bitcoin ·
    GitHub (gribble,
    19:04:23)
- https://github.com/bitcoin/bitcoin/issues/15118
    | Refactor block file logic by jimpo · Pull Request #15118 ·
    bitcoin/bitcoin · GitHub (gribble,
    19:04:33)
- https://github.com/bitcoin/bitcoin/issues/15118
    | Refactor block file logic by jimpo · Pull Request #15118 ·
    bitcoin/bitcoin · GitHub (gribble,
    19:05:15)
- https://github.com/bitcoin/bitcoin/issues/14121
    | Index for BIP 157 block filters by jimpo · Pull Request #14121 ·
    bitcoin/bitcoin · GitHub (gribble,
    19:05:19)
- https://github.com/bitcoin/bitcoin/issues/13932
    | Additional utility RPCs for PSBT by achow101 · Pull Request #13932
    · bitcoin/bitcoin · GitHub (gribble,
    19:05:42)
- https://github.com/bitcoin/bitcoin/issues/15225
    | GUI: Change the receive button to respond to keypool state
    changing by achow101 · Pull Request #15225 · bitcoin/bitcoin ·
    GitHub (gribble,
    19:08:00)
- https://github.com/bitcoin/bitcoin/issues/15118
    | Refactor block file logic by jimpo · Pull Request #15118 ·
    bitcoin/bitcoin · GitHub (gribble,
    19:08:02)
- https://github.com/bitcoin/bitcoin/issues/15141
    | Rewrite DoS interface between validation and net_processing by
    sdaftuar · Pull Request #15141 · bitcoin/bitcoin · GitHub (gribble,
    19:10:04)
 
 
- Globals and initialization order (sipa) (wumpus, 19:11:07)
  - https://github.com/bitcoin/bitcoin/issues/14955
    | Switch all RNG code to the built-in PRNG by sipa · Pull Request
    #14955 · bitcoin/bitcoin · GitHub (gribble,
    19:16:36)
 
 
- Chaincode summer residency (jnewbery) (wumpus, 19:32:39)
  - https://github.com/bitcoin/bitcoin/issues/14929
    | net: Allow connections from misbehavior banned peers by gmaxwell ·
    Pull Request #14929 · bitcoin/bitcoin · GitHub (gribble,
    19:42:36)
- ACTION: review
    #14929 (wumpus,
    19:43:18)
- https://github.com/bitcoin/bitcoin/issues/14929
    | net: Allow connections from misbehavior banned peers by gmaxwell ·
    Pull Request #14929 · bitcoin/bitcoin · GitHub (gribble,
    19:43:21)
 
Meeting ended at 19:47:19 UTC
(full logs).
Action items
  - review #14929
People present (lines said)
  - wumpus (49)
- sipa (33)
- jnewbery (19)
- gribble (17)
- gmaxwell (12)
- jamesob (5)
- instagibbs (4)
- promag (4)
- sdaftuar (4)
- luke-jr (3)
- gwillen (3)
- provoostenator (3)
- achow101 (3)
- meshcollider (2)
- lightningbot (2)
- phantomcircuit (1)
- jimpo (1)
- moneyball (1)
- marcinja (1)
- kanzure (1)
- promag_ (1)
- jonasschnelli (1)
Generated by MeetBot 0.1.4.