19:03:23 <jonatack> #startmeeting
19:03:23 <lightningbot> Meeting started Fri Sep 27 19:03:23 2019 UTC.  The chair is jonatack. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:23 <lightningbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:03:32 <meshcollider> Thanks jonatack :)
19:03:34 <kanzure> hi
19:03:35 <achow101> walletmeeting?
19:03:52 <meshcollider> #bitcoin-core-dev Wallet Meeting: wumpus sipa gmaxwell jonasschnelli morcos luke-jr sdaftuar jtimon cfields petertodd kanzure bluematt instagibbs phantomcircuit codeshark michagogo marcofalke paveljanik NicolasDorier jl2012 achow101 meshcollider jnewbery maaku fanquake promag provoostenator aj Chris_Stewart_5 dongcarl gwillen jamesob ken281221 ryanofsky gleb moneyball
19:04:25 <jonatack> hi. topics?
19:04:54 <provoostenator> Topic suggestion: GUI send wizard
19:05:29 <jonatack> #topic GUI send wizard
19:05:34 <provoostenator> Feedback welcome on #16966
19:05:36 <gribble> https://github.com/bitcoin/bitcoin/issues/16966 | ui: make send a wizard by Sjors · Pull Request #16966 · bitcoin/bitcoin · GitHub
19:05:46 <achow101> cool
19:06:00 <provoostenator> I'm especially trying to figure out how to "store" the pending transaction in the dialog
19:06:16 <provoostenator> Normally a fresh transaction uses WalletTransactionModel, a QT only thing
19:06:24 <provoostenator> BUmp fee uses CMutableTransaction
19:06:29 <provoostenator> And cool people use PSBT
19:07:07 <provoostenator> The current version just switches between WalletTransactionModel and CMutableTransaction (and PSBT if I were to add it).
19:07:52 <provoostenator> There's three stages to the wizard: draft, sign and finish (broadcast).
19:07:55 <meshcollider> Looks cool provoostenator :)
19:08:39 <provoostenator> Draft is the same as our current send screen. Sign is our current confirmation screen (send & bump fee). Finish (broadcast) sends the transaction and displays a summary.
19:09:03 <provoostenator> My idea is to expand Sign with a list of connected hardware wallets in a followup.
19:09:32 <provoostenator> And to expand Finish / Broadcast with PSBT export for offline signers (based on gwillen's stuff)
19:09:59 <provoostenator> And when you load a PSBT file, it will jump straight to the Sign step if it needs your signature, and to the Finish step if not.
19:10:08 <provoostenator> So I think it's a nice enough abstraction.
19:12:06 <jonatack> Sounds great :) will try to review soon. Anything more on the wizard?
19:12:43 <jonatack> Other topics?
19:13:17 <jonatack> #action Review PR #16966
19:13:19 <gribble> https://github.com/bitcoin/bitcoin/issues/16966 | ui: make send a wizard by Sjors · Pull Request #16966 · bitcoin/bitcoin · GitHub
19:13:22 <jonatack> #endmeeting