#lightning-dev Meeting
Meeting started by cdecker at 19:06:11 UTC
(full logs).
Meeting summary
- 
  - https://paper.dropbox.com/doc/Lightning-Spec-Meeting-20200120--Asyn1LqwS5eymCtfthi~KR01Ag-SA160p27VepiVZcnbKcZE
    (cdecker,
    19:07:49)
 
 
- Restrict data_loss_protect to init context #726 (cdecker, 19:10:30)
  - https://github.com/lightningnetwork/lightning-rfc/pull/726
    (cdecker,
    19:10:38)
- AGREED: cdecker to
    close #726 with a brief explanation (cdecker,
    19:25:16)
 
 
- 09+11: require transitive feature dependencies #719 (cdecker, 19:25:32)
  - https://github.com/lightningnetwork/lightning-rfc/pull/719
    (cdecker,
    19:25:40)
- AGREED: cdecker to
    merge #719 (cdecker,
    19:28:32)
 
 
- Specify that resolution of amount is msat #700 (cdecker, 19:28:43)
  - https://github.com/lightningnetwork/lightning-rfc/pull/700
    (cdecker,
    19:28:51)
- AGREED: cdecker to
    rephrase #700 to match the previous line and merge after acks on
    Github (cdecker,
    19:33:11)
 
 
- Add bolt11 test vector with amount in `p` units #699 (cdecker, 19:33:24)
  - https://github.com/lightningnetwork/lightning-rfc/pull/699
    (cdecker,
    19:33:33)
- ACTION: rusty to
    clean up test vector (using correct privkey) and also add some
    negative tests in another PR. (rusty,
    19:36:36)
 
 
- BOLT 1: Define custom message type range #705 (cdecker, 19:37:52)
  - https://github.com/lightningnetwork/lightning-rfc/pull/705
    (cdecker,
    19:38:04)
- ACTION: cdecker to
    merge #705 (cdecker,
    19:42:06)
 
 
- BOLT-04: modify Sphinx packet construction to use starting random bytes#697 (cdecker, 19:42:32)
  - https://github.com/lightningnetwork/lightning-rfc/pull/697#
    (cdecker,
    19:42:40)
- ACTION: cdecker to
    implement updated padding and merge #697 if test-vectors pass
    (cdecker,
    19:45:04)
 
 
- Stuck channels because of small fee increase#728 (cdecker, 19:45:46)
  - https://github.com/lightningnetwork/lightning-rfc/issues/728#
    (cdecker,
    19:45:54)
- ACTION: everybody to
    brainstorm the issue on Github and come up with potential solutions
    for the next meeting (cdecker,
    20:01:34)
 
 
- Current status of the dual funding proposal (cdecker, 20:02:33)
  - ACTION: everyone to
    take a look at "dual-funding, the monster"
    ElementsProject/lightning#3418 :-) (cdecker,
    20:25:00)
 
Meeting ended at 20:32:20 UTC
(full logs).
Action items
  - rusty to clean up test vector (using correct privkey) and also add some negative tests in another PR.
- cdecker to merge #705
- cdecker to implement updated padding and merge #697 if test-vectors pass
- everybody to brainstorm the issue on Github and come up with potential solutions for the next meeting
- everyone to take a look at "dual-funding, the monster" ElementsProject/lightning#3418 :-)
Action items, by person
  -  cdecker 
    - cdecker to merge #705
- cdecker to implement updated padding and merge #697 if test-vectors pass
 
-  rusty 
    - rusty to clean up test vector (using correct privkey) and also add some negative tests in another PR.
 
- UNASSIGNED
    - everybody to brainstorm the issue on Github and come up with potential solutions for the next meeting
- everyone to take a look at "dual-funding, the monster" ElementsProject/lightning#3418 :-)
 
People present (lines said)
  - cdecker (113)
- t-bast (65)
- niftynei (41)
- roasbeef (36)
- rusty (31)
- ariard_ (15)
- BlueMatt (4)
- lightningbot (2)
- lndbot (2)
Generated by MeetBot 0.1.4.