#lightning-dev Meeting
Meeting started by niftynei at 20:08:05 UTC
(full logs).
Meeting summary
- 
  - https://github.com/lightningnetwork/lightning-rfc/issues/768
    (niftynei,
    20:09:06)
 
 
- stuck channels #740 (niftynei, 20:10:02)
  - https://github.com/lightningnetwork/lightning-rfc/pull/740
    (niftynei,
    20:10:16)
- ACTION: t-bast to
    squash/merge PR #740 for stuck channels (niftynei,
    20:16:43)
 
 
- PR #767 prune channels with old channel_updates (niftynei, 20:17:32)
  - https://github.com/lightningnetwork/lightning-rfc/pull/767
    (niftynei,
    20:17:34)
- ACTION: rusty to
    figure out c-lightning pruning reality (niftynei,
    20:33:30)
- ACTION: discussion
    for PR 768 to continue on github (niftynei,
    20:33:42)
 
 
- issue 761, which is a discussion branched off of 740 (niftynei, 20:34:44)
  - https://github.com/lightningnetwork/lightning-rfc/issues/761
    (niftynei,
    20:34:44)
- ACTION: roasbeef to
    check thread out (niftynei,
    20:39:44)
- "it's the nature of the beast" - rusty
    (niftynei,
    20:40:02)
 
 
- long term updates: blinded paths cc t-bast (niftynei, 20:42:35)
  - https://github.com/lightningnetwork/lightning-rfc/pull/765
    (t-bast,
    20:43:32)
- ACTION: t-bast to
    investigate making fee/cltv uniform in the blinded path, describe
    that in the PR (t-bast,
    20:59:39)
- ACTION: discussion to
    continue on PR (niftynei,
    21:05:08)
 
 
- long term updates: mempool tx pinning attack cc ariad & BlueMatt (niftynei, 21:05:40)
  - https://github.com/bitcoinops/bitcoinops.github.io/pull/394/files
    (ariard,
    21:06:55)
- https://lists.linuxfoundation.org/pipermail/bitcoin-dev/2020-April/017757.html
    ... (rusty,
    21:07:13)
- https://lists.linuxfoundation.org/pipermail/lightning-dev/2020-April/002639.html
    (niftynei,
    21:07:44)
- https://lists.linuxfoundation.org/pipermail/bitcoin-dev/2020-April/017757.html
    (niftynei,
    21:08:07)
- ttps://github.com/bitcoinops/bitcoinops.github.io/pull/394/files
    (niftynei,
    21:09:00)
- https://github.com/bitcoinops/bitcoinops.github.io/pull/394/files
    (niftynei,
    21:09:10)
- ACTION: amend anchors
    to make no changes to htlc signatures, and resolve the other issues
    (needs tests cases, debate about 1-vs-2 etc) on the ml or
    issue (niftynei,
    21:19:22)
- ACTION: work on
    redoing things to use anchors (maybe based on feerates) in htlc
    txn (niftynei,
    21:19:32)
 
Meeting ended at 21:21:36 UTC
(full logs).
Action items
  - t-bast to squash/merge PR #740 for stuck channels
- rusty to figure out c-lightning pruning reality
- discussion for PR 768 to continue on github
- roasbeef to check thread out
- t-bast to investigate making fee/cltv uniform in the blinded path, describe that in the PR
- discussion to continue on PR
- amend anchors to make no changes to htlc signatures, and resolve the other issues (needs tests cases, debate about 1-vs-2 etc) on the ml or issue
- work on redoing things to use anchors (maybe based on feerates) in htlc txn
Action items, by person
  -  roasbeef 
    - roasbeef to check thread out
 
-  rusty 
    - rusty to figure out c-lightning pruning reality
 
-  t-bast 
    - t-bast to squash/merge PR #740 for stuck channels
- t-bast to investigate making fee/cltv uniform in the blinded path, describe that in the PR
 
- UNASSIGNED
    - discussion for PR 768 to continue on github
- discussion to continue on PR
- amend anchors to make no changes to htlc signatures, and resolve the other issues (needs tests cases, debate about 1-vs-2 etc) on the ml or issue
- work on redoing things to use anchors (maybe based on feerates) in htlc txn
 
People present (lines said)
  - t-bast (67)
- niftynei (64)
- roasbeef (41)
- cdecker (29)
- BlueMatt (28)
- rusty (21)
- ariard (20)
- lightningbot (3)
- sstone (1)
Generated by MeetBot 0.1.4.