#lightning-dev Meeting
Meeting started by t-bast at 20:09:38 UTC
(full logs).
Meeting summary
- Update test vectors to static_remotekey (t-bast, 20:10:27)
  - https://github.com/lightningnetwork/lightning-rfc/pull/758
    (t-bast,
    20:10:30)
- ACTION: ACK on PR
    when test vectors have been verified by other implementations, then
    apply (t-bast,
    20:12:43)
 
 
- Clarify TLV record uniqueness in streams (t-bast, 20:13:02)
  - https://github.com/lightningnetwork/lightning-rfc/pull/777
    (t-bast,
    20:13:05)
- ACTION: bitconner to
    comment, condense rationale paragraphs and then apply (t-bast,
    20:15:37)
 
 
- varint / bigsize clarification (t-bast, 20:15:57)
  - https://github.com/lightningnetwork/lightning-rfc/pull/778
    (t-bast,
    20:15:59)
- ACTION: Decide
    whether we want to keep the paragraph mentioning Bitcoin varint or
    not, then apply (t-bast,
    20:22:34)
- ACTION: Apply
    #778 (t-bast,
    20:24:01)
 
 
- flip(B) is incorrectly implemented, so we instead fix the spec xD (t-bast, 20:24:18)
  - https://github.com/lightningnetwork/lightning-rfc/pull/779
    (t-bast,
    20:24:33)
- https://imgflip.com/i/42sldk
    (t-bast,
    20:31:03)
- ACTION: fix
    spellchecker, wait for ACKs and apply (t-bast,
    20:35:47)
 
 
- mempool-pinning issues (t-bast, 20:37:14)
  - ACTION: ariard to
    draft preimage-watching and htlc lockdown proposals (t-bast,
    21:16:52)
 
Meeting ended at 21:21:14 UTC
(full logs).
Action items
  - ACK on PR when test vectors have been verified by other implementations, then apply
- bitconner to comment, condense rationale paragraphs and then apply
- Decide whether we want to keep the paragraph mentioning Bitcoin varint or not, then apply
- Apply #778
- fix spellchecker, wait for ACKs and apply
- ariard to draft preimage-watching and htlc lockdown proposals
Action items, by person
  -  ariard 
    - ariard to draft preimage-watching and htlc lockdown proposals
 
-  bitconner 
    - bitconner to comment, condense rationale paragraphs and then apply
 
- UNASSIGNED
    - ACK on PR when test vectors have been verified by other implementations, then apply
- Decide whether we want to keep the paragraph mentioning Bitcoin varint or not, then apply
- Apply #778
- fix spellchecker, wait for ACKs and apply
 
People present (lines said)
  - t-bast (75)
- ariard (74)
- roasbeef (67)
- cdecker (52)
- bitconner (16)
- harding (3)
- michaelfolkson (3)
- lightningbot (2)
- ja (1)
Generated by MeetBot 0.1.4.