#lightning-dev Meeting
Meeting started by niftynei at 20:11:28 UTC
(full logs).
Meeting summary
- 
  - agenda at
    https://github.com/lightningnetwork/lightning-rfc/issues/790
    (niftynei,
    20:12:00)
 
 
- CLTV delta recommendations (niftynei, 20:13:18)
  - https://github.com/lightningnetwork/lightning-rfc/pull/785
    (niftynei,
    20:13:27)
- ACTION: t-bast to
    update PR: bolt 11 writers MUST specify
    min-final-expiry-delta (t-bast,
    20:17:41)
 
 
- PR #787 add missing MAC check in Act Three (niftynei, 20:19:08)
  - https://github.com/lightningnetwork/lightning-rfc/pull/787
    (niftynei,
    20:19:12)
- ACTION: niftynei to
    merge PR #787 (niftynei,
    20:23:06)
 
 
- FoaF and rebalancing (niftynei, 20:25:22)
  - https://github.com/lightningnetwork/lightning-rfc/pull/780
    (niftynei,
    20:26:52)
- ACTION: renepick1 to
    consider feedback and update proposal/PR etc (niftynei,
    20:44:29)
 
 
- anchor outputs (niftynei, 20:44:50)
  - https://github.com/lightningnetwork/lightning-rfc/pull/688
    (niftynei,
    20:45:20)
- ACTION: t-bast +
    rusty to work on interop testing with lnd's anchor outputs impl;
    will update at next spec meeting (niftynei,
    20:54:05)
 
 
- protocol test suite (niftynei, 20:54:25)
  - https://github.com/rustyrussell/lnprototest
    (rusty,
    20:55:04)
- https://github.com/rustyrussell/lnprototest
    (niftynei,
    20:55:28)
- ACTION: niftynei to
    write dual funding prototests to dogfood the lnprototest docs
    (niftynei,
    21:02:00)
- ACTION: lnd + eclair
    to investigate the runner implementation requirements (time
    permitting) ;) (niftynei,
    21:03:01)
 
Meeting ended at 21:03:59 UTC
(full logs).
Action items
  - t-bast to update PR: bolt 11 writers MUST specify min-final-expiry-delta
- niftynei to merge PR #787
- renepick1 to consider feedback and update proposal/PR etc
- t-bast + rusty to work on interop testing with lnd's anchor outputs impl; will update at next spec meeting
- niftynei to write dual funding prototests to dogfood the lnprototest docs
- lnd + eclair to investigate the runner implementation requirements (time permitting) ;)
Action items, by person
  -  niftynei 
    - niftynei to merge PR #787
- niftynei to write dual funding prototests to dogfood the lnprototest docs
 
-  renepick1 
    - renepick1 to consider feedback and update proposal/PR etc
 
-  rusty 
    - t-bast + rusty to work on interop testing with lnd's anchor outputs impl; will update at next spec meeting
 
-  t-bast 
    - t-bast to update PR: bolt 11 writers MUST specify min-final-expiry-delta
- t-bast + rusty to work on interop testing with lnd's anchor outputs impl; will update at next spec meeting
 
People present (lines said)
  - niftynei (46)
- t-bast (36)
- rusty (35)
- roasbeef (31)
- renepick1 (24)
- cdecker (12)
- lndbot (8)
- lightningbot (2)
Generated by MeetBot 0.1.4.